Genesis G70 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
We have had our G70 in the dealership 4 times over last few month due to the auto start stop feature shuts down. The system makes you do a full restart. We have several close calls of being hit at stop lights due to this. The car has been in the dealership over 50 days due to this. The dealership can’t pinpoint the issue.
 

·
Registered
Joined
·
489 Posts
This won't be the first time I've heard of this from a Genesis product.
50 days is quite a lot, almost enough for it to fall under your local lemon law, I think. Have you checked? I also suggest reaching out to Genesis corporate and maybe another dealer for a second opinion/see their response.

Keep us posted.
 

·
Registered
Joined
·
4 Posts
Did you ever get this fixed??
I have the same issue
We have had our G70 in the dealership 4 times over last few month due to the auto start stop feature shuts down. The system makes you do a full restart. We have several close calls of being hit at stop lights due to this. The car has been in the dealership over 50 days due to this. The dealership can’t pinpoint the issue.
 

·
Registered
Joined
·
6 Posts
Did you ever get this fixed??
I have the same issue
I AM TOO!!! This is the second time at the shop in two months they can’t figure out how to recreate the issue so they can’t seem to figure it out! I have stalled out at multiple traffic lights and stop signs- and I’m not sure what triggers the issue either!
Any updates??
 

·
Registered
Joined
·
4 Posts
I AM TOO!!! This is the second time at the shop in two months they can’t figure out how to recreate the issue so they can’t seem to figure it out! I have stalled out at multiple traffic lights and stop signs- and I’m not sure what triggers the issue either!
Any updates??
I had a radar detector and a dash cam installed ( i had them hard wired), I took them both out and it hasnt happened again since but its only been about 2 weeks. Do you have anything aftermarket installed? Maybe this could be the answer
 

·
Registered
Joined
·
6 Posts
I had a radar detector and a dash cam installed ( i had them hard wired), I took them both out and it hasnt happened again since but its only been about 2 weeks. Do you have anything aftermarket installed? Maybe this could be the answer
Thank you for your response!
How many miles do you hve on yours!? State!?
I’m in jersey about 12k on her. First time it happened I thought it was a fluke it didn’t happen again for at least 4 months and ever since then about 1-2 times a month— last time was June 2nd and it hasn’t happened since however it’s just a waiting game at this point idk when it will or won’t happen.
I have No After Market things installed.
 

·
Registered
Joined
·
4 Posts
I have 15k miles on mine in New Hampshire. It started happening a few months after I got it. When the issue happened it wouldn't let me restart the car for a few minutes leaving me stuck on the road and in some pretty unsafe situations.
 

·
Registered
Joined
·
6 Posts
I have 15k miles on mine in New Hampshire. It started happening a few months after I got it. When the issue happened it wouldn't let me restart the car for a few minutes leaving me stuck on the road and in some pretty unsafe situations.
EXACTLY! Top time I’ve been stuck was at a light for 15min extremely dangerous cop called a tow truck and I was finally able to restart it ((I pumped the brakes and it finally turned on)) so I canceled the tow. & drove it to the dealer— they couldn’t recreate the issue— I videotaped it on June 2nd and showed them this time they are keeping it for the weekend. I just knew I couldn’t be the ONLY ONE having this issue!
 

·
Registered
Joined
·
4 Posts
EXACTLY! Top time I’ve been stuck was at a light for 15min extremely dangerous cop called a tow truck and I was finally able to restart it ((I pumped the brakes and it finally turned on)) so I canceled the tow. & drove it to the dealer— they couldn’t recreate the issue— I videotaped it on June 2nd and showed them this time they are keeping it for the weekend. I just knew I couldn’t be the ONLY ONE having this issue!
We’re you able to figure out what it was? I started having this issue this week again :(
I’m probably gonna drop off the car at the dealer next week.
 

·
Registered
Joined
·
6 Posts
We’re you able to figure out what it was? I started having this issue this week again :(
I’m probably gonna drop off the car at the dealer next week.
You should deff drop it off! Mine seems to happen about once a month so far!... but no the dealer couldn’t recreate the issue- I recorded it with my phone so they know it’s happening! I’m waiting for it to happen again it’s been about 2 weeks with my car back so far it’s fine it’s just a waiting game. HOWEVER I did put a complaint into genesis directly! Go to their website they have an option for it so you can report it— they just sent my claim to higher management and I’m waiting for a call.
 

·
Registered
2020 G70 Elite Package
Joined
·
18 Posts
Sorry you have this problem
I was suprised my 2020 3.3T AWD model didnt come with that feature which I was happy about because I was never a fan with any manufacturers use of it. Scares me actually to know the thing shuts down.wish you the best of luck demanding answers and wish I could help.
 

·
Registered
Joined
·
6 Posts
We’re you able to figure out what it was? I started having this issue this week again :(
I’m probably gonna drop off the car at the dealer next week.
Upper management did reach out to me- they said they have one other claim at this time reporting the same issue- they want me to drop the car at the dealer with no set time on recieving it back- they said that an engineer might have to take a look at it- not just a mechanic.
I am happy to see they are taking it more seriously since it is extremely dangerous as we can not pinpoint when it will happen to us!
Please keep me posted and reach out to genesis directly from their website so that they can better help you! Be safe!
 

·
Registered
Joined
·
6 Posts
Sorry you have this problem
I was suprised my 2020 3.3T AWD model didnt come with that feature which I was happy about because I was never a fan with any manufacturers use of it. Scares me actually to know the thing shuts down.wish you the best of luck demanding answers and wish I could help.
Billy thank you! Genesis seems to be taking the problem more seriously now I will keep the thread updated-
 
1 - 14 of 14 Posts
Top